Back to overview
Downtime

Perks Unavailable on WorkPerks

Jul 07 at 10:10pm CST
Affected services
team.venngo.com

Resolved
Jul 07 at 10:17pm CST

Issue has been resolved.

Updated
Jul 07 at 10:15pm CST

We have identified the root cause of the issue. It will be resolved within 5 minutes. Thanks for your patience!

Created
Jul 07 at 10:10pm CST

Our WorkPerks platform is experiencing issues fetching Perks from an internal service which is causing users to not see the offers. The team is aware of this issue and is actively working on finding a fix.